Movable Type 4 beta 2が旧SQLite非対応に

先日試用したMovable Type 4のbeta 1(2007/06/05版)が多くの不具合を抱えている状態だったので新たに公開されたbeta 2(2007/06/12版)にアップデートしてみることにしました。

今回のアップデートによりSQLite使用時のセッション切れの問題が解消されることを期待していたのですが、mt-check.cgiを動かしてみると「DBD::SQLiteがない」としてインストールすらできない状態になっていました。

MT4の更新履歴を眺めていると「DBD::SQLite2を含むDBD::SQLite 1.10以前は対応しません」といった記述。テスト環境にしているファーストサーバで使えるモジュールはSQLite2とSQLite 1.08なので、これがアップデートされないことにはSQLiteを使ったMT4の稼働は出来ない模様。

MT4はBerkeley DBに非対応だし、今のファーストサーバとの契約ではMySQLも使えないのでお手上げ。ファーストサーバにモジュールのアップデートを依頼しようにも、技術力のある会社ではないので対応は難しそう…。。

うーん、困った。

    This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

    • 頂戴したコメントは管理者に承認されるまで表示されません。
    • メールアドレスが公開されることはありません。